sábado, 15 de octubre de 2011

La función SUMAR.SI.CONJUNTO en Excel



La función SUMAR.SI.CONJUNTO se utiliza para sumar los valores numéricos de todas las celdas de un rango que cumplan con una o más condiciones. Tiene como mínimo 3 argumentos separados por punto y coma y encerrados entre paréntesis:

= SUMAR.SI.CONJUNTO (rango_suma;rango_criterio1;criterio1;[rango_criterio2];[criterio2])

  • Rango_suma: es el rango de celdas donde están los valores que queremos sumar.
  • Rango_criterio1: es el rango de celdas donde están los valores que queremos utilizar como primera condición.
  • Criterio1: es la primera condición que queremos poner para que una celda de rango_suma sea incluida en la suma.
  • [Rango_criterio2]: Es opcional y se refiere al rango de celdas donde están los valores que queremos utilizar como segunda condición.
  • [Criterio2]: Es opcional y se refiere a la segunda condición que queremos poner para que una celda de rango_suma sea incluida en la suma.

Es importante saber que:

  • Rango_suma y Rango_criteriox deben tener la misma cantidad de filas y columnas.


  • SÍ se incluirán en la suma los valores lógicos VERDADERO / FALSO (como uno o cero).
  • En los argumentos criteriox se pueden utilizar caracteres comodín  ?   y   * para celdas que contengan información con formato de texto.

Ejemplos de utilización del caracter   ?


  • "=Villa*"   selecciona para sumar, todos los registros que en rango_criteriox , empiecen por Villa
  • "=*ez" selecciona para sumar, todos los registros que en rango_criteriox ,  haya apellidos terminados en ez
  • "=AXT899-?" selecciona para sumar, todos los registros que en rango_criteriox ,  haya códigos que empiezan por AXT899- , independientemente de cuál sea el último caracter.
  • ">66"  selecciona para sumar, todos los registros que en rango_criteriox , haya cantidades superiores a 66.


Hay que resaltar la necesidad (como se ha podido comprobar) de poner entre comillas las expresiones de los criterios, aunque estén referidas a números.




  José Manuel Pomares Medrano



13 comentarios:

  1. Estimados,
    tengo una duda respecto al referenciar un criterio en una celda. Ejemplo
    a1 b1
    01-01-2013 10
    a2 b2
    01-02-2013 20

    C1 03-01-2013
    D1 31-01-2013

    quiero sumar todos los valores de la columna B, que sean mayores a la columna c1 y menores a la columna d1.

    Sumar.si.conjunto(B1:B2;A1:A2;>=c1;A1:A2<=d1)
    el problema me queda con los signos de mayor igual o menor, y ya no se me ocurre como puedo hacer esto


    Sldos y gracias.
    AAAA

    ResponderEliminar
    Respuestas
    1. No podemos ayudarte si no nos envías una explicación más detallada o un archivo Excel con la explicación a josempomares@temporaconsultores.com

      Eliminar
    2. Debes usar Sumar.si.conjunto(B1:B2;A1:A2;">="&c1;A1:A2;"<="&d1)

      Eliminar
  2. ¿Puede ayudarme alguien? No tengo ni idea de como realizar la sigueinte operacion:Sumar celdas A1 mas B1 y solo en el caso de que el contenido de B1 sea igual a cero, sumar la C1. muchisimas gracias

    ResponderEliminar
  3. En la celda J13 quiero realizar la operacion siguiente =Si(H13=4;G13*H13/100) y realmente me la hace sin problemas. Lo que me ocurre es que hasta que introduzco datos en las celdas G13 y H13, en el interior de la celda J13 me aparece la palabra FALSO ¿Que tendria que hacer para que quedara en blanco hasta que introduzca los datos? Gracias anticipadas

    ResponderEliminar
    Respuestas
    1. Cambia la fórmula por esta siguiente:

      =Si(H13=4;G13*H13/100;"")

      Realmente, te falta el tercer argumento de la función SI, que es... ni más ni menos que lo que tú quieres que te devuelva cuando la evaluación H13=4 sea falsa. Por lo tanto, solo faltaba añadir un punto y coma y un par de comillas como tercer argumento.

      Eliminar
    2. Muchisimas gracias

      Eliminar
    3. Cuándo realizo la siguiente operación:
      M13=F13+G13+I13+J13+K13-L13 sujeto a las siguientes condiciones:
      1º) El contenido de la F13 solo se sumará cuando el de G13=0
      2º) La I13 solo tendrá contenido si la H13 = 4. El saldo de la I13 será el 4% de la cantidad que figura en la G13.
      3º) La J13 solo tendrá contenido si la H13 =10. El saldo de la J13 será el 10% de la cantidad que figura en la G13.
      4º) La K13 solo tendrá contenido si la H13 = 21. El saldo de la K13 será el 21% de la cantidad que figura en la G13.
      5º) La L13 puede ser cualquier valor numérico
      LA EXPRESION QUE UTILIZO ES:
      =SI(G13=0;F13+G13+I13+J13+K13-L13;G13+I13+J13+K13-L13)
      Siendo I13 la siguiente expresión =SI(H13=4;G13*H13/100;””)
      Siendo J13 la siguiente expresión =SI(H13=10;G13*H13/100;””)
      Siendo K13 la siguiente expresión =SI(H13=21;G13*H13/100;””)
      Pues bien al realizar tal operación en la celda M13 me aparece lo siguiente #¡VALOR! Sin que se realice las operaciones aritméticas especificadas, a pesar de que al pinchar en el interior de la celda me aparece reflejada la siguiente expresión: SI(G13=0;F13+G13+I13+J13+K13-L13;G13+I13+J13+K13-L13)
      Le ruego mil perdones por las molestias que pueda causarles. Gracias, pero es que no sé como resolver el tema

      Eliminar
    4. Sustituye las comillas por un cero en los condicionales SI.
      Si quieres que Excel sume, debes poner ceros, puesto que las comillas pertenecen al mundo del "texto" para Excel.
      Saludos.

      Eliminar
    5. De4 nuevo: Muchisimas gracias

      Eliminar
  4. Como puedo utilizar la sintaxis, si deseo sumar una variable ü otra que corresponden a la misma columna.
    Ejemplo

    texto 1 texto 2
    5001 10
    5002 1
    5003 5
    5004 1
    5001 5
    5005 1
    5003 5

    en este caso deseo sumar del texto 1 los códigos 5001 y 5003

    ResponderEliminar